Like every other website on the planet, SmallNetBuilder uses cookies. Our cookies track login status, but we only allow admins to log in anyway, so those don't apply to you. Any other cookies you pick up during your visit come from advertisers, which we don't control.
If you continue to use the site, you agree to tolerate our use of cookies. Thank you!

Router Charts

Click for Router Charts

Router Ranker

Click for Router Ranker

NAS Charts

Click for NAS Charts

NAS Ranker

Click for NAS Ranker

More Tools

Click for More Tools

LAN & WAN How To

Testing

To test things out, I set up an IxChariot test using the FTPget script. This script emulates an entire FTP session including logon, download and logoff. I found that bandwidth control worked as you might expect, although there were a few oddities.

I first took a baseline measurement using the 512 Kbps WAN Up and Downstream Bandwidth settings and no applications set for rate control. Figure 5 shows that the FTP script clocked in around 65 Mbps.

FTP download with default settings (no bandwidth limit)
Click to enlarge image

Figure 5: FTP download with default settings (no bandwidth limit)

Since I was doing testing locally on my LAN, I then entered 90000 Kbps (90 Mbps) for the Upstream and Downstream values. These are a little below the typical 100 Mbps Ethernet performance that I measure with IxChariot. (It would be handy if an "auto" option were included like D-Link's Ubicom Stream Engine based products have, but no such luck.)

But something didn't like those settings, as Figure 6 illustrates. Download throughput was initially limited to around 5 Mbps, not 500 Kbps and then jumped back up to the previously-measured unlimited value.

FTP download - 500 Kbps limit, 90000 Kbps WAN
Click to enlarge image

Figure 6: FTP download - 500 Kbps limit, 90000 Kbps WAN

So I moved the WAN bandwidth settings back to the default 512 Kbps settings and finally got the desired limiting, as shown in Figure 7. Although it's not exactly 500 kbps, it's sure close enough for me!

FTP download - 500 Kbps limit, 512 Kbps WAN
Click to enlarge image

Figure 7: FTP download - 500 Kbps limit, 512 Kbps WAN

I tried the same experiments on the RVL200 and got similar results. Default FTP throughput was around 31 Mbps with the RVL200's default WAN bandwidth of 512 Kbps. Setting 500 Kbps rates and the WAN bandwidth to 90000 Kbps produced throughput of around 20 Mbps. It wasn't until I set the WAN bandwidth back to 512 Kbps that I got the desired throughput of slightly above 500 Kbps. So it looks like the best thing to do is to leave the default bandwidth values alone!

Closing Thoughts

I am surprised that there aren't more (and less expensive) off-the-shelf options for managing download bandwidth. The lowest price for the RVL200 as I write this is $138 and the RV042 is closer to $150. While these aren't outrageous costs, they are about 4X what you'd pay for a simple 100 Mbps wired-only router. And you have to accept VPN and other features that you may not want or need.

The other weaknesses of the Linksys options as compared to pfSense are the absence of session monitoring and control and real-time bandwidth graphs. The ability to monitor (and kill) active sessions is very helpful when you are trying to track down a bandwidth abuser. And while there are other ways to get bandwidth graphs, having the feature built in provides a quick and easy way to confirm that your settings are doing what you intended them to do.

But for those who don't get their kicks from setting up DIY routers, it's nice to know that you do have store-bought options when you need to clamp down on bandwidth piggies.

More LAN & WAN

Wi-Fi System Tools
Check out our Wi-Fi System Charts, Ranker and Finder!

Support Us!

If you like what we do and want to thank us, just buy something on Amazon. We'll get a small commission on anything you buy. Thanks!

Over In The Forums

Hi there,I am planning to use a spare unused ac68u as a switch. Could you guys please recommend the best way. Set it as an AP with disabled WiFi, or a...
I purchased a used RT-AC66U off ebay to use as an access point. It did not come with a power supply and I was good with that because I had an old one ...
Available by firmware update check.Not posted to the website yet.
So I upgraded(?) from my not so trusty RT-N66U to a shiny new RT-AC86U in the hope of getting a little more wi-fi range. Unfortunately I occasionally ...
I was trying to figure out if I could install the Amateur Radio AMPRNET rip44d on a ASUS RT-AC-5300. I would be following the guidelines for OpenWRT: ...

Don't Miss These

  • 1
  • 2
  • 3