Like every other website on the planet, SmallNetBuilder uses cookies. Our cookies track login status, but we only allow admins to log in anyway, so those don't apply to you. Any other cookies you pick up during your visit come from advertisers, which we don't control.
If you continue to use the site, you agree to tolerate our use of cookies. Thank you!

Router Charts

Click for Router Charts

Router Ranker

Click for Router Ranker

NAS Charts

Click for NAS Charts

NAS Ranker

Click for NAS Ranker

More Tools

Click for More Tools

NAS Reviews

Hands On

Once the EDR was configured, I had no problems finding it on my Windows network. I was surprised, however, that with only the default “guest” user defined, when mapping a drive, I had to click to open the device and use the guest/guest login credentials. Most of the other NASes I’ve reviewed allow a guest connection to the public share without authentication. Of course, if your user account on the NAS matches your windows name and password, you won’t have any problems.

I tried accessing the EDR via FTP. The EDR allows up to eight connections, but doesn’t support anonymous FTP. FTP clients such as WS-FTP won’t have any problems, but for browser-based access, you’ll need to use the following format: ftp://username:password@IP_Address.

I plugged in several USB drives, which the EDR immediately recognized and had no problem mapping drives to them.  By default, no users are assigned to USB shares—you have to add users to the USB shares before they can be used on the network.

USB

Click to enlarge image

Figure 12: USB Drives are recognized immediately when plugged in

The real measure of a NAS that supports RAID is how well it handles a disk failure. Do you lose your data? What happens if a drive goes bad? What happens depends on how you’ve configured the RAID. To demonstrate this, I created a test scenario which I’ve documented in a separate slideshow.

Initially, the EDR was configured for RAID 10 and 100% of the space was allocated for shared folders. I set up users, groups and shares and copied data. I also tried to use the backup software to protect a partition on one of my systems, but the backup failed because there was no unallocated space on the RAID.

I then decided to reconfigure the RAID for RAID 5 + Spare. In this configuration, data and parity are striped across three drives, and the fourth drive is online as a spare, should any of the three drives fail. As warned, I lost all data when I reconfigured to RAID 5 + Spare.

The RAID array reconfigured fairly quickly, and I had access within minutes, albeit at reduced performance. However, the EDR took more than 14 hours to fully synchronize the new array and restore full performance! Note that if another drive failure occurs while an array is being resynced, you lose all data.

Once the RAID 5 + spare configuration had synchronized, I copied additional data to the drive and successfully backed up a notebook partition to the EDR. I then intentionally failed the drive in bay one by pulling it out. I still had access to my data, and was able to continue to back up my notebook partition. 

Immediately after pulling the bay one drive, the spare drive in bay four started rebuilding. 13 hours and 23 minutes later, the new drive had synchronized and the RAID was again fault-tolerant.  I then re-inserted the original “failed” spare back into slot one.  Immediately the EDR recognized the drive and designated it as the spare.

Under the Advanced menu, the Disk sub-menu shows the model, serial numbers, size disk status and a “hot plug” indicator for each drive. A green hot plug indicator means that removing the drive will have no impact on the RAID. Yellow indicates that removing the drive (or if it fails) will cause the RAID to operate in a degraded state. Red means that the RAID will fail and data loss will occur if the drive fails.

Check out the slideshow Look for the hot plug indicators in the slideshow.

More NAS

Wi-Fi System Tools
Check out our Wi-Fi System Charts, Ranker and Finder!

Support Us!

If you like what we do and want to thank us, just buy something on Amazon. We'll get a small commission on anything you buy. Thanks!

Over In The Forums

Hi everybody,I have a RT-AC2900 (AC-86U) router with Merlin 384.17 and it is frequently rebooting automatically with this message:May 5 07:05:10 kerne...
I have attached a 2TB WD elements and partitioned it for 1.8TB for network share and 200GB for use with jffs partition on a RTAC88U with Merlin 384.18...
Tried to overclock my router, instead brought down my BogoMIPS to 10% of original values. And yes, it can be felt in the router UI, everything is much...
v2.1.0 Updated 2020-08-03 The concept for this script was originally developed by @h0me5k1nEasy management of your VPN Client connections for variou...
Asuswrt-Merlin 384.19 beta is now available (except for the RT-AX56U which won't be available for this release, due to outdated GPL code).The main cha...

Don't Miss These

  • 1
  • 2
  • 3