Like every other website on the planet, SmallNetBuilder uses cookies. Our cookies track login status, but we only allow admins to log in anyway, so those don't apply to you. Any other cookies you pick up during your visit come from advertisers, which we don't control.
If you continue to use the site, you agree to tolerate our use of cookies. Thank you!

Router Charts

Click for Router Charts

Router Ranker

Click for Router Ranker

NAS Charts

Click for NAS Charts

NAS Ranker

Click for NAS Ranker

More Tools

Click for More Tools

NAS Reviews

Drive Fail Test

Jim Buzbee previously ran a pull-a-drive fail test on the N4300N. So I didn't expect to find much different with my quick little test. I did put a bit of a twist in the test and first started a RAID 1 to RAID 0 migration!

When I pulled the top drive, its front panel light immediately went out and the System Status light turned from green to red. Within five seconds, the system buzzer sounded two loud beeps and continued to do so every 10 seconds, even after I reinserted the drive. The only way that I could find to silence the beeping was to reboot the unit.

Figure 9 shows that the system seemed confused by what I had done. The RAID Status showed as Offline, but note the Action Status, Background Activity and Progress indicators stayed the same as when the migration was running.

RAID Management screen with pulled drive
Click to enlarge image

Figure 9: RAID Management screen with pulled drive

I also quickly received this email notification, which confirmed a problem.

Notification from NS2300N (ns2300n_261739) !

Message: RAID status: "OFFLINE".
The NS2300N (ns2300n_261739) volume "/VOLUME1" is offline.

Date : May 11 2000 07:57:53

Since I had "broken" the system during a transitional state, I expect the RAID 1 array to be completely fried. And so it seemed, since attempting to access the shares while the drive was pulled were unsuccessful. But when I reinserted the drive, things were not as I expected.

First, the system kept on with its periodic beeping. Then I received a stream of these email alerts, which were sent at approximately 10 second intervals:

Notification from NS2300N (ns2300n_261739) !

Message: RAID status: "FUNCTIONAL".
The NS2300N (ns2300n_261739) volume "/VOLUME1" is functioning correctly.

Date : May 11 2000 08:01:51

If the system were "functional", then why the continued beeping and why keep sending me messages? Clearly something was still not right. A visit back to the File System Management page showed an Offline RAID Status. So at least that was correct. To try to silence the beeping, I reinserted the drive. The RAID Management page changed its RAID Status back to Functional, but visiting the File System Management screen showed conflicting information (Figure 10). If the array were "Functional", then why present the option to "Rebuild File System"?

File System Management screen with reinserted drive

Figure 10: File System Management screen with reinserted drive

I decided to not rebuild the file system, but instead rebooted the NAS to see what would happen and got quite a surprise! Thankfully, the beeping had stopped and so had the email alerts. But upon revisiting the File System Status Screen I found a "Functional" RAID 1 array and the RAID Management screen indicated that Migration had resumed! I then tried to access each share and found each one to be available. And much to my surprise, the shares where I had previously copied data before I started the fail test showed that the data were intact!

So even though the status information was pretty funky, I have to give Promise an "attaboy" for the 2300N's ability to not lose data during this unusual test.

More NAS

Wi-Fi System Tools
Check out our Wi-Fi System Charts, Ranker and Finder!

Support Us!

If you like what we do and want to thank us, just buy something on Amazon. We'll get a small commission on anything you buy. Thanks!

Over In The Forums

Asuswrt-Merlin 384.13_2 (RT-AC87U and RT-AC3200), and 384.14 (other models) are now available.The 384.13_2 release mostly focuses on fixes backported ...
I have an asus rtn16 router with 2 laptops using the wireless network. I have an older HP laptop that I get download speeds using ookla download test ...
I was recently given a sonos beam for a birthday present so I connected it up to my rt ac 88 u running 13 . Now I can get the google assistant to work...
Hi..I have been looking and looking online for a few days now and I cannot find the answer to my question.Based on the research I've done on AiMesh, i...
Greetings, All.I am trying to figure out if I am just spinning my wheels, wasting time, and worse — wasting precious memory on my router, or if what I...

Don't Miss These

  • 1
  • 2
  • 3