Like every other website on the planet, SmallNetBuilder uses cookies. Our cookies track login status, but we only allow admins to log in anyway, so those don't apply to you. Any other cookies you pick up during your visit come from advertisers, which we don't control.
If you continue to use the site, you agree to tolerate our use of cookies. Thank you!

Router Charts

Click for Router Charts

Router Ranker

Click for Router Ranker

NAS Charts

Click for NAS Charts

NAS Ranker

Click for NAS Ranker

More Tools

Click for More Tools

NAS Reviews

Internal Details

I didn't take the UMP completely apart and didn't really have to. There isn't much inside, only two 750GB Seagate Barracuda 7200.10 (ST3750840AS) drives and a small circuit board, visible in Figure 3.

UltraMax Pro internal assembly view
Click to enlarge image

Figure 3: UltraMax Pro internal assembly view

The heard of the UMP is a Silicon Image Sil5744 Storage Processor (near the lower left corner of the board),which handles all RAID duties for both USB and eSATA connections. The USB / Firewire version uses a different device, which is probably not from Silicon Image, whose Storage Processor lineup doesn't include any FireWire models.

In Use

Once I set the volume configuration using the rear panel switches, I connected it to the Vista SP1-based NAS testbed system for formatting. Windows supports only NTFS formatting of volumes over 32 GB. But Iomega includes a FAT32 formatting utility if you want to use that most widely-supported format and can live with its 4 GB file size limit.

The Iomega FAT32 Formatter utility seemed to work ok to format RAID 0 and 1 volumes. You will need to use the Windows Disk Manager to create a RAW partition first, however. I found that the utility will even work with a NTFS-formatted volume, although you need to run it twice and ignore the format fail messages it will throw.

There really isn't much more to the set up. The Vista system had no problem recognizing the UMP when connected via either USB or eSATA. Iomega's documentation notes that eSATA is not plug-and-play like USB and recommends powering down both the host system and the UMP when connecting and disconnecting eSATA.

By the way, the HTML user manual that came on the UMPs included CD is out of date and lacking important information. So be sure to download the latest version from the Iomega support site.

Drive Fail

With no admin interface and no monitor utility, it's up to you to interpret the indicator lights on the UMP's front panel to see what it is up to. This was a challenge when I performed a pull-a-drive test on a RAID 1 array.

Iomega's instructions emphasize that you must leave the UMP powered up when replacing a failed drive. So I started a long file copy, then pulled the top drive and waited to see what happened. Contrary to the Iomega manual, I did not see a red light to indicate a failed drive. Instead I saw a flashing green light in the top light group that started immediately after I pulled the drive.

Shortly after the drive was pulled, the file copy progress indicator stopped and I eventually had to kill the process. But I was able to access files on the UMP with the drive pulled out without a problem and also able to restart another file copy.

I then reinserted the top drive and the green indicator continued to blink. But the User Manual said that I should see a flashing blue light to indicate a RAID rebuild, which I never did see. The top green light continued to blink, even after I deleted all the files on the UMP and emptied the Recycle bin that is visible in the UMPs root directory.

I waited around 15 minutes and then shut down Vista and then powered off the UMP. Then I turned the UMP back on and booted Vista. Vista came up fine and showed the UMP both in My Computer and in the Windows Disk Utility. But the green light continued to flash, even with everything appearing to be ok. I think the light means that the RAID 1 array is still rebuilding, but have no way of knowing for sure, since there is no way to query the UMP to see where it is in the rebuild process. By the way, the light continued to flash until I shut down the system that it was attached to.

More NAS

Wi-Fi System Tools
Check out our Wi-Fi System Charts, Ranker and Finder!

Support Us!

If you like what we do and want to thank us, just buy something on Amazon. We'll get a small commission on anything you buy. Thanks!

Over In The Forums

I am a bit out of my depth setting up my 4G modem to integrate with my wireless router and would really appreciate some advice.The equipment I am repl...
Sorry. Please feel free to use "wow; stupid". Why is he allowed to have a computer; let alone a computer.I have used the Merlin firmware for years (an...
Hi,I have RT-AC86U running on Merlin 384.13_0. My Internet speed 1 gigabit from Comcast.I am getting the speed around 400 MB/s when the router works n...
Have a primary cable and a dsl backup.The AC86U is set to fall-over to the dsl if the cable goes down unfortunately this tends not to work worth a dam...
I am wanting to unbrick a tp link router and need to connect to it via a ethernet cable but I am wanting to do it with a windows surface pro 6 tablet....

Don't Miss These

  • 1
  • 2
  • 3