Like every other website on the planet, SmallNetBuilder uses cookies. Our cookies track login status, but we only allow admins to log in anyway, so those don't apply to you. Any other cookies you pick up during your visit come from advertisers, which we don't control.
If you continue to use the site, you agree to tolerate our use of cookies. Thank you!

Router Charts

Click for Router Charts

Router Ranker

Click for Router Ranker

NAS Charts

Click for NAS Charts

NAS Ranker

Click for NAS Ranker

More Tools

Click for More Tools

NAS Reviews

Performance - File Copy

Since we're just starting DAS coverage, I experimented a bit with a few performance measures. I tried our NAS iozone and Vista filecopy test tools and also tried HD Tune. I found that iozone, even when I used the -c switch, which in NAS across-the-network testing has the effect of removing higher-than-network-speed cached performance, provided results that were above both the 150 MB/s and 300 MB/s maximum transfer rates of 1.5 and 3.0 Gbps SATA connections until file sizes grew above 256 MBytes (Figure 4).

iozone performance

Figure 4: iozone performance

On the other hand, the Vista SP1 filecopy results were more realistic. Figure 5 is a summary of the write test results with the UMP configured in RAID 0 and 1 and with FAT32 and NTFS formatting. The USB 2.0 connection is clearly limiting the UMP's performance to the low 20 MB/s range. With a switch to the eSATA connection, write speeds jump to almost 108 MB/s for RAID 0, FAT 32 and 96 MB/s with RAID 0, NTFS.

Vista SP1 Filecopy write performance summary

Figure 5: Vista SP1 Filecopy write performance summary

The read test summary shown in Figure 6 again shows USB 2.0 connected performance in the 20 MB/s range, but slightly higher than write. The eSATA results are once more much higher, although only reaching a maximum of 83 MB/s for RAID 0, NTFS format.

Vista SP1 Filecopy read performance summary

Figure 6: Vista SP1 Filecopy read performance summary

These above results are all obtained with Windows drive write caching disabled because the Windows properties for the drive said that its write cache setting couldn't be modified (Figure 7). Each value is also the average of three filecopy runs.

Write caching can't be changed

Figure 7: Write caching can't be changed

More NAS

Wi-Fi System Tools
Check out our Wi-Fi System Charts, Ranker and Finder!

Support Us!

If you like what we do and want to thank us, just buy something on Amazon. We'll get a small commission on anything you buy. Thanks!

Over In The Forums

Sorry. Please feel free to use "wow; stupid". Why is he allowed to have a computer; let alone a computer.I have used the Merlin firmware for years (an...
Hi,I have RT-AC86U running on Merlin 384.13_0. My Internet speed 1 gigabit from Comcast.I am getting the speed around 400 MB/s when the router works n...
Have a primary cable and a dsl backup.The AC86U is set to fall-over to the dsl if the cable goes down unfortunately this tends not to work worth a dam...
I am wanting to unbrick a tp link router and need to connect to it via a ethernet cable but I am wanting to do it with a windows surface pro 6 tablet....
Hey everyone!Normally I'm good at figuring these kinds of issues out, but I am really struggling with this router... and now after finding this forum ...

Don't Miss These

  • 1
  • 2
  • 3