Like every other website on the planet, SmallNetBuilder uses cookies. Our cookies track login status, but we only allow admins to log in anyway, so those don't apply to you. Any other cookies you pick up during your visit come from advertisers, which we don't control.
If you continue to use the site, you agree to tolerate our use of cookies. Thank you!

Wi-Fi Router Charts

Click for Wi-Fi Router Charts

Mesh System Charts

Click for Wi-Fi Mesh System Charts


I've been praising mesh Wi-Fi kits that support the ability to mix-and-match, and add new nodes as time goes by and your needs change (or you discover that you underpurchased to begin with) for awhile now. ASUS has taken this concept a welcome step further with AiMesh, which is their branded way of describing doing the same thing with one or more routers.

A few ASUS AiMesh routers

A few ASUS AiMesh routers

Rather than buying a router and then figuring out "this isn't enough, I need mesh" and having wasted the initial $150-$300 you spent, you can simply add more routers later to extend your network.

AiMesh is obviously a great idea. But what's it really like to live with? Is it easy to set up, configure and maintain? Does it perform well? And how does it compare in pricing to purpose-built mesh kits?

To find the answers, I set up an ASUS RT-AC1900P in AiMesh router mode, and added two ASUS RT-AC68Us as AiMesh nodes. Both models feature identical upright chassis with three external antennas, a 3x3 dual-band Broadcom BCM4360 wifi chipset and dual-core Broadcom CPUs. The only real difference between the two is the CPU speed - the RT-AC1900P has a 1.4 GHz BCM4709C0, while the RT-AC68U has an 800 MHz BCM4708A0.

Initial Setup

Setting up my first AiMesh network was a pleasantly simple process. Since it had the fastest CPU, I elected to make my RT-AC1900P the main router for the AiMesh network. I first set it up as you would any router; I plugged it in, found its default Wi-Fi network, connected to it and browsed to the .1 IP address on the subnet it offered.

This walked me through the usual sort of wizard, during which I was asked to change the default username and password, change the Wi-Fi network name(s) and the password to access them. The setup wizard defaulted to a single SSID for the BCM4360's 2.4 GHz and 5 GHz radios, with Smart Connect (band steering) enabled. This is, in my experience, the configuration most people want from their network gear. Unfortunately, band steering is something ASUS isn't very good at yet, and that's going to cause us some problems down the road.

Once I'd nexted my way through the initial setup wizard, waited for the RT-AC1900P to reboot (which is pleasantly quick compared to most consumer routers), connected to the new SSID and logged back in, I saw there was no AiMesh option offered on the Administration page under Operation Mode. I assumed, correctly, this meant that the shipping firmware predated this feature.

Heading off to the Administration page presented me with a semi-automatic firmware update option (it didn't check for me, but had a button which would go search ASUS' website for newer firmware once clicked). Clicking worked as expected; new firmware was found and installed, and after another reboot and router login, the missing "AiMesh" Operation Modes were available. I clicked "AiMesh Router", and after another reboot, had an empty AiMesh Nodes section showing on the front page of the router UI.

I deliberately set up review kits differently than I do my own gear. When I'm setting up devices in production, I err on the side of making the configuration as easy on the designers (and therefore as likely to work the first time) as possible. When setting up devices for review, I do the exact opposite, and take the laziest route possible that seems the most likely to uncover a corner case the engineers didn't think of.

So when I set up the first of my two RT-AC68U routers, and saw that it already had AiMesh options available, I didn't update its firmware first - I just rushed straight into "AiMesh node" and waited to see what upgrading the firmware would look like after it was a part of my new AiMesh network. Returning to the RT-AC1900P, I clicked "Scan for AiMesh Nodes", and it found and added my first node uneventfully.

Adding my first AiMesh Node was quick and easy

Adding my first AiMesh Node was quick and easy

For the second RT-AC68U, I didn't even do that much - I literally just plugged it in and ignored it. Worse, I plugged it in downstairs, hugging the back wall, where it would be able to see the upstairs AiMesh Node, but would not be able to see the AiMesh Router itself.

To my surprise and delight, when I returned to the RT-AC1900P and clicked "scan for AiMesh Nodes" again, it found and cheerfully added my second RT-AC68U to the network. This was despite the fact that I'd just pulled out of the box, plugged it in where the router itself wouldn't be able to see it, and ignored any initial setup to put it in "AiMesh Node" operation mode specifically.

Adding the second AiMesh Node was also very easy

Adding the second AiMesh Node was also very easy

Upgrading the firmware on the two AiMesh Node routers turned out to be a little more frustrating, however. Once they've been added to your network, each Node shows up with its own icon on the front page of the AiMesh Router's configuration screen. From there, you can see each Node's IP address, and you can (and should!) give it a friendly alias. I named mine "Living room TV" and "Downstairs Den".

What you can't see is any sort of option to check or upgrade their firmware. The next step I tried was browsing to their IP addresses, as shown in the Node configuration. While they did answer my browser, all they did was HTTP 302 redirect me to the AiMesh Router's own login page. Finally, I tried checking the AiMesh Router's own firmware update page - and there they were.

Firmware upgrades are done from the AiMesh Router's own firmware upgrade dialog

Firmware upgrades are done from the AiMesh Router's own firmware upgrade dialog

There's still only a single button next to the AiMesh Router itself for "Check Firmware", and it's not clear from looking whether it will check and upgrade all three or only the router itself - but it does work, although a bit unpredictably. It took me three tries (and three reboots) of clicking the same button before it finally managed to upgrade the second RT-AC68U, but it eventually did get there, and all was well.

Configuration And Maintenance

Configuring an AiMesh network is, for the most part, exactly what most people would want it to be. You configure your AiMesh Router exactly as you'd normally configure it, and whatever settings you configure there are automatically passed down to the AiMesh Node router "children".

ASUS has an admirably complete set of functions in their router interfaces, and I couldn't find any of them missing after the RT-AC1900P was configured to AiMesh Router mode. It was the exact same router, only now I had three, all automagically configured the same way.

AiMesh's central configuration management works well

AiMesh's central configuration management works well

Unfortunately, what you can't do is configure your AiMesh nodes to use different Wi-Fi channels than your AiMesh router. Both 2.4 GHz and 5 GHz radios on all AiMesh nodes will be set to the same values as your AiMesh Router... even if you've got wired backhaul between the nodes and router. This maximizes airtime congestion in your network, since every single device can "hear" (and talk over) one another, and there's nothing you can do about it.

A final note about maintenance. The identical chassis I mentioned in the introduction caused me some difficulties later on, as neither RT-AC68U nor RT-AC1900P showed the actual model number on the front of the chassis. Both simply state "AC1900 dual band router" on the front, and reserve the actual model number for the extremely fine, dull brown print on the back.

I usually physically label all devices in a mesh kit before I begin testing, but this time I skipped that step - and it bit me hard when I needed to set things up a second time after initially breaking them down. I had lost track of which device was which and spent an embarrassingly long and frustrated time trying to figure out why my RT-AC1900P AiMesh Router wasn't recognizing its WAN connection! I finally realized I'd plugged one of the RT-AC68U AiMesh Nodes in its place. Learn from my mistakes! If you have any network kit involving multiple physically identical nodes, label them appropriately during the setup process!

Support Us!

If you like what we do and want to thank us, just buy something on Amazon. We'll get a small commission on anything you buy. Thanks!

Don't Miss These

  • 1
  • 2